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1 Lean Six Sigma - A Primer 

Lean Six Sigma is a quality management methodology and a customer-focused change strategy to 

improve performance.  You can also look at it as a collection of tools, or rather a toolbox, for fixing 

processes. 

Any toolbox is only as useful as the tools it contains. Before we get into the tools themselves and how 

MindManager is a welcome addition, let's review some of the key components of Lean Six Sigma. 

Lean Six Sigma, as the name implies, is a combination of Lean Manufacturing and Six Sigma 

methodologies. Lean has a long history dating back to the Middle Ages, long before the Industrial 

Revolution when the Venetians developed techniques for mass-producing warships in the Arsenal of 

Venice.  But it was Henry Ford who is credited with the modern concept of Lean since he integrated an 

entire production process into what we know as the assembly line.  Lean can be summarized as the means 

by which we eliminate waste in processes, specify and make value flow in the customer's eyes, and pursue 

perfection through continuous improvement. 

 

Six Sigma traces its origins to quality management fundamentals developed in the 1980s by Motorola, 

and later by General Electric in the early 1990s. It has a similar definition to Lean, in that it is focuses on 

improving the performance of processes to satisfy customers and enhance bottom-line results, but it 

takes a more statistical approach in doing so.  The Six Sigma name is derived from the Greek letter sigma 

σ, and refers to the population standard deviation, which is a measure of the variation in the data set 

collected about a process.  A Six Sigma process is one in which the 'mean' or process average is six 

standard deviations away from the nearest specification limit. Another way of explaining a Six Sigma 

process in terms of capability is in the number of defects per opportunity. A Six Sigma process is one that 

produces a 99.99966% yield and thus has only 3.4 defects per million opportunities. 
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Together, Lean and Six Sigma, hereinafter referred to as Lean Six Sigma, offers a set of tools that can be 

used in any environment, whether it be manufacturing, e-commerce, healthcare, financial services, law 

offices, retail, education, or your unique organization to decrease costs, increase revenue, and ultimately 

improve overall performance. 

1.1 The DMAIC Methodology 

Companies can employ different Lean Six Sigma strategies to reduce variation and waste in their 

organization, three of which are known as DMAIC, DMADV, and DSFF. This whitepaper focuses on DMAIC, 

which stands for Define, Measure, Analyze, Improve, and Control.  

Although DMAIC was not part of the original development of Lean Six Sigma, it rapidly became a core 

component and has helped many organizations achieve long-lasting results.  Each of the five steps in the 

DMAIC approach has a distinct purpose and set of tools to help Define the problem, Measure how bad it 

is, Analyze the root causes and options for solving the issue at hand, Improving the process, and, finally, 

putting a Control plan in place to ensure the process remains stable. 

Let’s explore just some of the ways MindManager can help you plan and execute a successful Lean Six 

Sigma project! 
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2 MindManager Tools for Lean Six Sigma 

2.1 DEFINE 

In the Define step, we agree on the nature of the problem, who the customers and stakeholders are, both 

internal and external, and their requirements. During this stage, we also develop the project plan with 

attainable and realistic milestones, and then create a high-level process map. Tools used in this phase 

include Affinity Diagrams, Failure Modes and Effects Analysis (Risk Analysis), and Value Steam Mapping.  

MindManager has several built-in templates that can be used to help with the Define stage. One of the 

first activities is identifying the stakeholders, characterizing them, and then conducting stakeholder 

analysis.  First, we need to understand the relationship between the various players (the suppliers and 

customers) and the process steps.  This involves a SIPOC analysis - SIPOC stands for Suppliers, Inputs, 

Process steps, Outputs, and Customers. The following SIPOC tool was created in MindManager: 

 

Once the stakeholders are identified, we can analyze them using a map part in MindManager specifically 

designed for this purpose: 

 

Then we need to kick off the project and begin understanding the nature of the problem.  Pick an 

appropriate template from the Meetings and Events menu to create a meeting agenda, plan a meeting 

and conduct a brainstorming session: 
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Plan it like any project! 

There are many types of Lean Six Sigma projects, and they can be used to address a variety of key 

performance indicators (also known as quality characteristics) that are in need of improvement. 

 

Often, organizations have so many processes that need optimization that it is necessary to prioritize the 

improvement projects. MindManager can help with this by creating a project prioritization map to assess 

the ease of implementation and the relative benefits of each project. Go to File > New, and select 

Strategic Planning > Matrix – Value-Effort: 
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 A completed matrix will look like the one below: 
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Once the project is selected, it needs to be planned using project management best practices, and that 

means creating a Work Breakdown Structure for the project. Refer to this whitepaper titled “Project 

Planning with a Visual Work Breakdown Structure” for details on how MindManager can help you create a 

winning WBS.  

Start by opening a new map, then select Org Chart under Layout in the Design menu. Name your Lean Six 

Sigma project using the central topic and begin identifying the project deliverables: 

 

 

 You can very rapidly use this mind map to create the deliverables for your Lean Six Sigma project, as per 

the example below. 

  

https://go.mindjet.com/rs/370-EGL-103/images/Project_Planning_with_a_Visual_WBS_EN.pdf
https://go.mindjet.com/rs/370-EGL-103/images/Project_Planning_with_a_Visual_WBS_EN.pdf
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Of course, you can use whatever format you prefer to lay out your project. For instance, this radial view 

works just as well, so long as all the elements are included and represent the totality of the project, along 

with applicable task information and dates: 
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When expanded, the above WBS looks like this: 

 

Gantt Charts 

Once the WBS components have been given start and due date information and dependencies, select the 

Gantt chart icon at the bottom of the mind map window to view tasks on a Gantt timeline. MindManager 

comes with a built-in core Gantt charting capability.  

It is also possible to adjust the task information directly within the Gantt chart, and to have MindManager 

display the Critical Path (and critical tasks) for the project.  The Critical Path is defined as the longest 

sequence of activities in a project plan which must be completed on time for the project to achieve the 

due date. 
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The result will be a Gantt chart that can be displayed either above, below, to the left or to the right of the 

WBS map.  It offers more features than the core Gantt and can be opened in a new window for display on 

a separate monitor. In the image below, the Gantt chart for the Lean Six Sigma project was produced by 

Gantt Pro: 

 

2.2 MEASURE 

During the Measure phase, we gather the necessary data to understand the performance of the process. 

One of the elements of the Measure phase is a refinement of the Value Stream Analysis. MindManager 

has powerful features that allow you to create a Value Stream Map (VSM) and input cycle time and delay 

information related to the process steps in the VSM: 
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A MindManager map is also very useful as a catchall file for storing all of the project artefacts.  Virtually 

any file format, such as an Excel spreadsheet or a Word doc, can be attached to the WBS element in 

MindManager, thus keeping all project files in one place. 

To attach a file to any element of the mind map, select the element, right-click, and select the Attach File 

item from the drop-down menu, or press Crtl+Shift+H. 

2.3 ANALYZE 

In the Analyze phase, we seek to understand the nature and source of the problems in the process. 

Various tools can help us in this phase, like the 5-Whys Analysis, which we use by asking "why?" up to five 

times to get to the root cause of a problem.  MindManager makes it easy to create tools of this nature. 
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Another commonly used tool in this phase is the Ishikawa or Fishbone Diagram. These are available in 

several formats such Manufacturing, Market, or Services. Simply create a new mind map under File > New, 

and select the Problem Solving folder under Professional Templates. 

 

Once you have opened Problem Solving templates, select your applicable Fishbone diagram. See the 

Service Fishbone Analysis template below: 

 

The output of a Fishbone diagram can be unwieldy, and it is often useful to group the resulting 

information into an Affinity diagram. MindManager can create such a diagram with ease. Go to File > 

New, select Matrix Diagram: 
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This template allows you to place floating topics into various boxes. Add rows and columns as needed. 

2.4 IMPROVE 

Improvements implementation is the phase where mind maps can also be of great assistance in 

brainstorming ideas for problem solving and ensuring the right solutions are in place to complete 

projects.  

Brainstorming is a great way to engage a team in a creative way to solve a problem.  It has many benefits, 

not the least of which is group cohesion. 

MindManager has a brainstorming template under File > New >  Meetings and Events: 
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Other tools include the 5S Tool for improving visual control in the workplace. 
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Pull Scheduling or Just-In-Time (JIT) is another common tool used in the Improve phase of a Lean Six 

Sigma project.  This is a system of production scheduling that pulls product through the value-stream in a 

continuous flow rather than pushing it through in batches.  The parts on demand mechanism is referred 

to as a Kanban - a card that specifies the number of parts that are to be moved.  MindManager has a 

built-in template for a Kanban. Go to File > New, and select Kanban from the list: 

:  

2.5 CONTROL 

The Control phase of a Lean Six Sigma project is, in a sense, the beginning of the new process that has 

been developed and tested.  This is all about maintaining the stability of the process that has been 

improved and involves the application of strategies for continuous improvement to ensure things do not 

go awry. 

A solid control plan along with error-proofing and training the process owner's team are the keys to long-

term sustainability of the improvements achieved in the project. 

MindManager is useful in this stage as a repository all of your documents and artifacts as attachments 

within the mind map. 
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3 Conclusion and Additional Resources 

Lean Six Sigma is a broad subject and there are many aspects to this methodology for process 

improvement.  Like any field, it has acronyms and terms that are specific to the Lean Six Sigma field like 

Takt Time, Kaizen, Nike, JIT, TQM, etc.  There are software packages and other tools that are specifically 

designed to provide the templates needed to conduct a DMAIC project, and these are necessary for any 

project that requires statistical data analysis. It is not the purpose of this paper to provide a 

comprehensive treatment of the subject. Instead, the goal is to present alternative tools available within 

MindManager that can complement and often replace other sources, some of which are listed below for 

reference. As mentioned earlier, one of MindManager's many powerful features includes the ability to 

save attachments within the elements of the mind map, thus allowing you to have a self-contained project 

file with all artefacts in one place. The ability to make notes within MindManager is also a powerful feature 

for producing reports.  For instance, this whitepaper, along with all images was written entirely in 

MindManager, and then exported to Microsoft Word. 

3.1 Resources 

One of the most useful tools in any Lean Six Sigma toolset is an advanced spreadsheet program like 

Microsoft Excel.  There are free or reasonably priced add-ons available for Excel that provide statistical 

packages for data preparation, conducting statistical and regression analysis, preparing control charts, and 

aiding with decision-making.  One add-on that the author recommends is PHStat.  Below is the menu that 

comes with this add-in: 

 

For advanced data analysis and Lean Six Sigma projects, the author recommends Minitab and Companion 

by Minitab, which are software tools that can be used in complement with MindManager. NOTE: Neither 

the author nor MindManager have any affilitation to Minitab.  
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Every Lean Six Sigma practitioner should have access to a good statistics manual, and there are many 

excellent ones to choose from, both in print and online.  Even a basic statistics manual will provide all the 

necessary formulae and tables needed by the average user.  The author has been using Statistics Manual, 

by Crow, Davis, and Maxfield for more than two decades. 

An excellent online resource for statistics is the free e-Handbook of Statistical Methods. 

Other recommended books include The Fifth Discipline, the Art and Practice of the Learning Organization 

and The Fifth Discipline Fieldbook, Strategies and Tools for Building a Learning Organization, both by Peter 

M. Senge. 

 

 

 

 

 

 

 

Please note that the author used MindManager 2019 for Windows to create this whitepaper, and 

the included screenshots. Some features may be different or not available in the Mac editions of 

MindManager, or in earlier editions of the Windows version.  

 

https://www.itl.nist.gov/div898/handbook/index.html

